最新消息:

yum升级中锁定指定软件版本禁止其升级(手动)

Linux运维 大步 1020浏览 0评论

上篇文章《CentOS / RHEL:yum升级时锁定特定软件版本》用于centos /rhel /redhat /federa 中,如果用“yum install yum-versionlock ”命令来安装versionlock,则是安装的旧的版本。所以,只能手动编辑versionlock的 锁定文件/etc/yum/pluginconf.d/versionlock.list 来实现锁定软件版本,而不能向上篇文章那样知直接用命令来操作。

yum相关文章:

yum 命令跳过特定(指定)软件包升级方法

用exclude参数(禁止)排除指定软件包被yum升级

CentOS / RHEL:yum升级时锁定特定软件版本

yum使用yum-plugin-security插件安全性升级

yum安装指定(特定)版本(旧版本)软件包的方法

yum –showduplicates 介绍和使用方法

 

Yum升级中锁定指定软件版本禁止其升级方法如下:

1.先安装versionlock,输入:

# yum install yum-versionlock

2.查看/etc/yum/pluginconf.d/versionlock.conf文件

#vi /etc/yum/pluginconf.d/versionlock.conf

显示为:

[main]
enabled = 1
locklist = /etc/yum/pluginconf.d/versionlock.list
# Uncomment this to lock out "upgrade via. obsoletes" etc. (slower)
# follow_obsoletes = 1

enabled = 0|1
开启或禁用versionlock
locklist = /path/to/file
定义versionlock锁定软件列表文件versionlock.list的绝对路径,这里/etc/yum/pluginconf.d/versionlock.list
/etc/yum/pluginconf.d/versionlock.list 中,锁定文件的格式为每行一个软件包名

确保文件中有 enabled = 1 ,没有则添加。安装后,默认enabled就是1,即versionlock插件开启状态。

 

3.添加需要被锁定的软件包到名字和版本到/etc/yum/pluginconf.d/versionlock.list中,每行一行软件包名

假设,我们要锁定nagios-plugins的版本不让yum将其升级,则将下面一行,复制到versionlock.list

nagios-plugins-1.4.11-1.el5.rf.x86_64

添加后保存versionlock.list 再试试用下面的命令尝试升级nagios输入

#yum update nagios-plugins

就会提示:

...
Setting up Update Process
No Packages marked for Update

 

技巧(tip)

其实更好的方法就是用管道命令,直接添加要锁定的软件包名字到versionlock.list,假设这里锁定ppp升级,则输入:

#rpm -qa | grep ppp >> /etc/yum/pluginconf.d/versionlock.list

然后,再检查是否添加成功,输入:

#cat /etc/yum/pluginconf.d/versionlock.list

如果显示:

ppp-2.4.4-2.el5

则说明添加成功!!

————————————————————————————————————————————————————

end!!!

英文原文:Force yum update Command To Exclude Certain Packages

转载请注明:大步's Blog » yum升级中锁定指定软件版本禁止其升级(手动)

发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

网友最新评论 (2)

SiteMap