最新消息:

yum安装指定(特定)版本(旧版本)软件包的方法

Linux运维 大步 13039浏览 0评论

有人会问道如何用yum安装指定(特定)版本(旧版本)软件包?

yum相关文章:

yum 命令跳过特定(指定)软件包升级方法

用exclude参数(禁止)排除指定软件包被yum升级

CentOS / RHEL:yum升级时锁定特定软件版本

yum升级中锁定指定软件版本禁止其升级(手动)

yum使用yum-plugin-security插件安全性升级

yum –showduplicates 介绍和使用方法

Answer :

yum默认都是安装最新版的软件,这样可能会出一些问题,或者我们希望yum安装指定(特定)版本(旧版本)软件包.所以,就顺带分享yum安装指定(特定)版本(旧版本)软件包的方法。

过程如下:

假设这里是我们想安装的是prce ,输入:

#yum         list          prce

输出:

找到你要安装的版本的完整的名字,这里安装pcre-7.8-6.el6.i686,输入:

#yum  install  pcre-7.8-6.el6.i686 -y

安装完后,就是检查pcre的版本了,输入:

# rpm -qa | grep pcre

就可以看到你安装的版本是不是你要的了。

 

end!

转载请注明:大步's Blog » yum安装指定(特定)版本(旧版本)软件包的方法

发表我的评论
取消评论

表情

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
SiteMap