最新消息:

The import com.google cannot be resolved

android 大步 2187浏览 0评论

今天导入一个Android 项目到Eclipse的时候提示“The import com.google cannot be resolved”。

原因:
代码中调用了谷歌的maps.jar包。而我们又没有将库包加入eclipse的编译路径中,所以报错。

 

 
 
解决办法:
1.先去SDK manager中下载对应版本的 google APIs 。我这里下载 15 版本
 

 

2.然后在对应的  android sdk目录下的  add-ons\addon-google_apis-google-15\maps.jar  。
 
 

 

3.将这个maps.jar包添加(导入)到你的项目的libs目录下(没有libs目录就自己创建个,至于如何导入,不懂的请google),就没有报错了。

转载请注明:大步's Blog » The import com.google cannot be resolved

SiteMap